Delay in receiving on Mathspace emails
Incident Report for Mathspace
Resolved
Upstream provider has resolved the issue. All emails should now be delivered promptly.
Posted 8 months ago. Feb 06, 2019 - 14:13 AEDT
Identified
There is a delay in emails from Mathspace being delivered to users.
Posted 9 months ago. Feb 06, 2019 - 09:51 AEDT